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Chapter 2
Basic Drawing and Editing Tools

In this chapter you learn how to use the basic drawing and editing tools that apply 
to almost all types of elements. These tools also include alignment lines, 
temporary dimensions, snaps, and the Properties palette. You learn how to select 
elements for editing. You also learn how to move, copy, rotate, mirror, and array 
elements and how to align elements, split linear elements, trim, extend, and offset 
elements.

This chapter contains the following topics:

General Drawing Tools

Editing Elements

Basic Modifying Tools

Helpful Editing Tools
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2.1 General Drawing Tools

When you start a drawing command, the contextual Ribbon, 
Options Bar, and Properties palette enable you to set up features 
for each element you are placing in the drawing. As you are 
drawing, several features called drawing aids display, as shown 
in Figure 2–1. They help create designs quickly and accurately. 

Figure 2–1

Contextual Ribbon

In the Select panel, click 

 (Modify) to finish the 
command and return to 
the main tab at any time.

When you select a command, the Ribbon displays the Modify tab 
with the contextual tools. For example, when you click

 (Duct), the Modify | Place Duct tab opens, as shown in 
Figure 2–1. 

 The Modify tools are always displayed to the left of the 
Ribbon and the contextual tools to the right with a green 
panel title.

Learning Objectives

Use contextual Ribbon tabs, the Options Bar and Properties 
as you draw and modify.

Draw elements using draw and pick tools.

Use drawing aids including alignment lines, temporary 
dimensions and snaps.
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Options Bar

The Options Bar displays the most used options for an element, 
as shown in Figure 2–2. These options are also typically found in 
the Properties palette.

Figure 2–2

Properties Palette

The Properties palette displays the current element type in the 
Type Selector. You can select other types and modify some of 
the related parameters for the selected object, as shown in 
Figure 2–3.

Some of the properties 
parameters are only 
available when you are 
editing an element. 
They are grayed out 
when you are creating 
an element.

Figure 2–3

 Changes in the palette do not take effect until you click  
or move your cursor away from the palette. If you click in the 
window, it applies the change but clears the elements.
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 The Properties palette can be floated and moved around the 
interface. You can also dock it on top of the Project Browser 
and then switch between them using the tabs at the bottom of 
the palette, as shown in Figure 2–4. 

To dock the palette, 
drag the titlebar over the 
titlebar of the Project 
Browser.

Figure 2–4

 If the Properties palette is toggled off, you can toggle it on by 

clicking  (Properties) in the Modify tab>Properties panel 
or by typing PP. This is an on/off toggle.

Drawing Aids As soon as you start drawing in the software, three drawing aids 
display on the screen: alignment lines, temporary dimensions, 
and snaps. These are available with most drawing and many 
modification commands.

Alignment Lines

Dashed alignment lines display as soon as you select your first 
point, as shown in Figure 2–5. They help keep lines horizontal, 
vertical, or at a specified angle. They also line up with the implied 
intersections of walls and other elements.

Angles display at 90, 45, 
15, 5, and 1 degree 
increments. The order of 
the angle list controls 
the power level of the 
snap. For example, the 
90 degree angle is most 
likely to display if you 
are close to horizontal 
or vertical.

Figure 2–5

 Hold down <Shift> to force the alignments to be orthogonal.
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Temporary Dimensions

Along with alignment lines, temporary dimensions display as you 
draw to help place linear elements at the proper length and 
location, as shown in Figure 2–6.

You can move the 
cursor to the exact 
dimension, or place it 
approximately and then 
modify the dimension as 
needed. This enables 
you to sketch the 
building and then come 
back and use the 
parametric engine to 
update the model with 
greater precision.

Figure 2–6

 For Imperial measurements (feet and inches), the software 
understands a default of feet. For example, when you type 4, 
it assumes 4’-0”. To indicate inches, type the inch mark (”) 
after the distance. For a distance such as 4’-6”, you can type 
any of the following: 4’-6”, 4’6, 4-6, or 4 6 (the numbers 
separated by a space). 

 The increments displayed for dimensions change as you 
zoom in closer to the elements. These dimension snap 
increments are for both linear and angular dimensions, and 
can be set in the Snaps dialog box.

 Temporary dimensions disappear as soon as you finish 
drawing linear elements. If you want to make them 
permanent, select the control shown in Figure 2–7.

Dimensions are a 
powerful tool to help 
create and annotate the 
model. Figure 2–7

 The size of the temporary dimensions, in pixels, can be set in 
the Options dialog box on the Graphics tab.

Snaps

Snaps are key points that help you reference existing elements 
to exact points when drawing, as shown in Figure 2–8.

Figure 2–8
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They include Endpoints, Midpoints, Nearest, Work Plane Grid, 
Quadrants, Intersections, Centers, Perpendicular, Tangents, and 
Points. When you move your cursor over an element, the Snap 
symbol displays. Each snap location type displays with a 
different symbol.

 To modify the snap settings, in the Manage tab>Settings 

panel, click  (Snaps). This opens the Snaps dialog box, 
where you can set which snap points are active, as well as 
the snap distances (for dimension and angular increments). It 
also shows the keyboard shortcuts for each snap, which you 
can use to override the automatic snapping.

Reference
Planes

As you develop designs in Autodesk® Revit® MEP, there are 
times when you need additional temporary lines to help you 
define certain locations. You can draw reference planes (the 
dashed lines) to host the height of sinks or to help you define 
centerlines and paths for ductwork, as shown in Figure 2–9. You 
can snap to reference planes and they display in associated 
views.

Figure 2–9

Hint: Temporarily Overriding Snap Settings

You can use shortcut key combinations (displayed in the Snaps 
dialog box) or right-click and select Snap Overrides to 
temporarily override snap settings. Temporary overrides only 
affect a single pick but can be very helpful when there are 
snaps nearby other than the one you want to use. 
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How to: Sketch with Reference Planes

1. In the Systems tab>Work Plane panel, click  (Ref Plane) 
or type RP. 

2. In the Modify | Place Reference Plane tab>Draw panel, click 

 (Line) or  (Pick Lines).

 For  (Line) select two points that define the reference 
plane. 

 For  (Pick Lines), select any linear element and a 
reference plane is created that matches the length of that 
element. 

3. Click  (Modify) when you have created all of the required 
reference planes.

 In the Options Bar, the Offset field enables you to enter 
values to draw the reference plane at a specified distance 
from the selected points. For example, set Offset to 10’-0" 
and select the end points of an existing wall to create a 
reference plane 10’-0" away. You can also use Offset with 
Pick Lines. 

 To change the length of a reference plane, drag the circle at 
either end.

 You can name reference planes. Select the reference plane 
and in the Identity Data area in Properties, type a name. 

Draw Tools The MEP tools (such as ducts, pipes, and conduit), are strictly 
straight linear elements that are automatically connected with 
elbows or tees. However, if you are working with walls, as shown 
in Figure 2–10, or lines used in details, legends, and schematic 
drawings, more tools are available. They display in the 
contextual Ribbon and the tools vary according to the element 
being drawn.
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Figure 2–10

 Two styles of tools are available: one where you draw the 
element using a geometric form, and another where you pick 
an existing element (such as a line, face, or wall) as the basis 
for the new element’s geometry.

How to: Draw Linear Elements

1. Start the command you want to use, such as  (Wall).
2. In the contextual tab>Draw panel, select a drawing tool, such 

as  (Line), as shown in Figure 2–11. Select points to define 
the walls using other drawing aids, such as temporary 
dimensions, alignment lines, and snaps.

You can change from 
one Draw tool to 
another in the middle of 
a command.

Figure 2–11

 You can also select a pick tool, such as  (Pick Lines), 

and select an element.  (Pick Face) is only available if 
you are in a 3D view.

3. Click  (Modify) to finish the command.
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Draw Tools

Line Draws a straight linear element defined by the 
first and last points. If Chain is enabled, you 
can continue selecting end points for multiple 
segments.

Rectangle Draws four linear elements defined from two 
opposing corner points. You can adjust the 
dimensions after selecting both points.

Inscribed 
Polygon

Draws a polygon inscribed in a hypothetical 
circle with the number of sides specified in the 
Options Bar.

Circumscribed 
Polygon

Draws a polygon circumscribed around a 
hypothetical circle with the number of sides 
specified in the Options Bar.

Circle Draws a circular linear element defined by a 
center point and radius.

Start-End-
Radius Arc

Draws a curved linear element defined by a 
start, end, and radius of the arc. The outside 
dimension shown is the included angle of the 
arc. The inside dimension is the radius.

Center-ends Arc Draws a curved linear element defined by a 
center, radius, and included angle. The 
selected point of the radius also defines the 
start point of the arc.

Tangent End 
Arc

Draws a curved linear element tangent to 
another element. Select an end point for the 
first point, but do not select the intersection of 
two or more elements. Then select a second 
point based on the included angle of the arc.

Fillet Arc Draws a curved linear element defined by two 
other linear elements and a radius. Because it 
is difficult to select the correct radius by 
clicking, this command automatically moves to 
edit mode. Select the dimension and then 
modify the radius of the fillet.

Spline Draws a curved linear element based on 
selected points. The curve does not actually 
touch the points (Model and Detail Lines only).

Ellipse Draws an ellipse from a primary and secondary 
axis (Model and Detail Lines only).

Partial Ellipse Draws only one side of the ellipse, like an arc. 
A partial ellipse also has a primary and 
secondary axis (Model and Detail Lines only).
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Pick Tools

Draw Options

When you are in Drawing mode, several options display in the 
Options Bar, as shown in Figure 2–12.

Other options display 
according to the type of 
element you are 
drawing.

Figure 2–12

 The Chain option controls how many segments are drawn in 
one process. If it is not selected, the Line and Arc tools only 
draw one segment at a time. If it is selected, you can continue 
drawing segments until you select the command again.

 The Offset field enables you to enter values to draw the linear 
elements at a specified distance from the selected points. For 
example, set Offset to 10’-0" and select the end points of an 
existing wall to create a new wall 10’-0" away.

 When using a radial draw tool, you can select the Radius 
option and add a radius in the edit field.

 To draw angled lines, move your cursor to the desired angle 
shown by the temporary dimensions, and type the distance 
value. The angle increments shown vary depending on how 
far in or out the view is zoomed.

Pick 
Lines

Use this option to select existing linear elements in the 
project. This is useful when you start the project from an 
imported 2D drawing.

Pick 
Face

Use this option to select the face of a 3D massing 
element (walls and 3D views only).

Pick 
Walls

Use this option to select an existing wall in the project to 
be the basis for a new sketch line (floors, ceilings, etc.).
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2.2 Editing Elements

Building design projects typically involve extensive changes to 
the positions of equipment, ducting, piping, and other elements. 

The Autodesk® Revit® software was designed to make such 

changes easy.  (Modify) works with all of the different 
element types.

 When you select an element during an active command, 
there are a number of ways to change it, as shown in 
Figure 2–13:

 Modify commands and element-specific tools display in 
the contextual tab in the Ribbon.

The Type Selector can 
also be found in the 
Modify tab of the Ribbon 
or on the Quick Access 
Toolbar.

 The Properties palette displays the Type Selector and 
associated parameters.

 Temporary dimensions enable you to change the 
element’s dimensions.

 Controls enable you to drag, flip, lock, and rotate the 
element.

 When you hover your cursor over an element, a tooltip 
displays information about it.

Figure 2–13

Learning Objectives

Select elements to modify.

Modify elements using the Ribbon, Properties, temporary 
dimensions, and controls.

Filter selection sets.

Temporary dimensions

Controls (and connectors)
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 Connectors are frequently linked to controls. Therefore, when 
the control is moved, the connector is moved with it. You 
should not disconnect systems when moving these controls. 

 To delete an element, select it and press <Delete>, right-click 

and select Delete, or click  (Delete) in the Modify panel.

 When working with temporary dimensions, the default 
location of the dimension line might not be where you need it. 
For example, as shown on the left in Figure 2–14, instead of 
setting the distance of the selected wall from the center of the 
left wall, you might want to modify the distance from the grid 
line. Drag the square control (also called the witness line) to 
the grid line, as shown on the right in Figure 2–14.

Figure 2–14

 You can click on the square control to move the witness line 
from one part of the selected element to another or drag it to 
a new location.

 The new location of a temporary dimension is remembered 
as long as you are in the same session of the software.

Hint: Nudge

Nudge is a feature that is often overlooked. It enables you to 
move an element in short increments. When an element is 
selected, you can press one of the four arrow (direction) keys to 
move the element in that direction. The snap increments 
specified in the Snap dialog box determine the distance that is 
applied each time the arrow keys are pressed, depending how 
far in or out you are zoomed. This is very useful with annotation 
elements.
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Selecting
Elements

You can select elements in several ways:

 To select a single element, place your cursor on the edge of 
the element and click to select.

 To add another element to a selection set, hold down <Ctrl> 
and select another item. 

 To remove an element from a selection set, hold down 
<Shift> and select the element.

 If you click and drag the cursor to window around elements, 
you have two selection options, as shown in Figure 2–15. If 
you drag from left to right, you only select the elements 
completely inside the window. If you drag from right to left, 
you select elements both inside and crossing the window.

Figure 2–15

 If several elements are on or near each other, press <Tab> to 
cycle through them before you click. If there are elements 
that might be linked to each other, such as ducts that are 
connected, pressing <Tab> selects the chain of elements.

 Press <Ctrl>+<Left Arrow> to reselect the previous selection 
set. You can also right-click in the drawing window with 
nothing selected and select Select Previous.

 To select all elements of a specific type, right-click on an 
element and select Select All Instances>Visible in View or 
In Entire Project, as shown in Figure 2–16.

Figure 2–16
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Hint: Selection Options

You can control how the software selects specific elements in a 
project by toggling them on and off on Status Bar or in the 
expanded Modify icon as shown in Figure 2–17.

Figure 2–17

  Select links: When toggled on, you can selected linked 
drawings or Autodesk Revit models. When it is toggled off 
you cannot select them when using Modify or Move.

  Select underlay elements: When toggled on, you can 
select underlay elements. When toggled off, you cannot 
select them when using Modify or Move.

  Select pinned elements: When toggled on, you can 
selected pinned elements. When toggled off, you cannot 
select them when using Modify or Move.

  Select elements by face: When toggled on you can 
select elements (such as the floors or walls in an elevation) 
by selecting the interior face or selecting an edge. When 
toggled off, you can only select elements by selecting an 
edge.

  Drag elements on selection: When toggled on, you 
can hover over an element, select it, and drag it to a new 
location. When toggled off, the Crossing or Box select mode 
starts when you press and drag, even if you are on top of an 
element. Once elements have been selected they can still 
be dragged to a new location.
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Modifying
Multiple

Elements

When multiple element types are selected, the Multi-Select 
contextual tab opens in the Ribbon, as shown in Figure 2–18. 
This gives you access to all of the Modify tools, as well as the 
Filter command and tools to create and use selection sets. 

Figure 2–18

 The Properties palette displays tools that are common to all 
element types if they are available. You can also select just 
one type and make modifications, as shown in Figure 2–19.

Figure 2–19

Filtering Selection Sets

The Filter command enables you to specify the types of 
elements to select. For example, you might only want to select 
lighting fixtures, as shown in Figure 2–20.

Figure 2–20
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How to: Filter a Selection Set

1. Select everything in the required area.

2. Click  (Filter) in the Modify | Multi-Select tab or in the 
Status Bar. The Filter dialog box opens, as shown in 
Figure 2–21.

The Filter dialog box 
displays all types of 
elements in the original 
selection.

Figure 2–21

3. Click  to clear all of the options and then 
select the element types that you want included in the 
selection.

4. Click . The selection set is now limited to the 
elements you specified.

 In the Status Bar,  (Filter) displays how many elements 
you selected.
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Reusing Selection Sets

When multiple elements types are selected you can save the 
selection set so that it can be reused. For example, a structural 
column and an architectural column need to move together. 
Instead of picking each element, create a selection set that you 
can quickly access as shown in Figure 2–22. You can also edit 
selection sets to add or remove elements from the set.

Figure 2–22

 Selection sets are a type of filter.

How to: Save Selection Sets

1. Select the elements that you want to include in the selection 
set.

2. In the Modify | Multi-Select tab>Selection panel, click

 (Save). 
3. In the Save Selection dialog box, type a name for the set as 

shown in Figure 2–23, and click .

Figure 2–23
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How to: Retrieve Selection Sets

1. Select any other elements you might want to use. In the 

Modify | Multi-Select tab>Selection panel, click  (Load). 
Alternatively, without any other selection, in the Manage tab>

Selection panel, click  (Load).
2. In the Retrieve Filters dialog box (shown in Figure 2–24), 

select the set that you want to use and click .

Figure 2–24

3. The elements are selected and you can continue to select 
other elements or use the selection.

How to: Edit Selection Sets

1. If elements are selected, in the Modify | Multi-Select tab>

Selection panel, click  (Edit). Alternatively, without any 

selection, in the Manage tab>Selection panel, click  (Edit).
2. In the Filters dialog box (shown in Figure 2–25), select the set 

that you want to edit and click .

Some filters in this 
dialog box are not 
selection sets but apply 
to categories of 
elements, such as the 
Interior filter shown in 
Figure 2–25.

Figure 2–25
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 If you want to modify the name of the Filter, click 

.

3. The selection set elements remain black while the rest of the 
elements are grayed out. The Edit Selection Set contextual 
tab displays as well, as shown in Figure 2–26.

Figure 2–26

4. Use  (Add to Selection) to select additional elements for 

the set and  (Remove from Selection) to delete elements 
from the set.

5. When you have finished editing, click  (Finish Selection).

6. In the Filters dialog box, click  to finish.
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2.3 Basic Modifying Tools

The Autodesk Revit software contains controls and temporary 
dimensions that enable you to edit elements. Additional 
modifying tools can be used with individual elements or any 
selection of elements. They are found in the Modify tab>Modify 
panel, as shown in Figure 2–27, and in contextual tabs.

You can either select 
the elements and start 
the command or start 
the command, select 
the elements, and press 
<Enter> to finish the 
selection set.

Figure 2–27

 The Move, Copy, Rotate, Mirror, and Array commands are 
covered in this topic. Other tools are covered later.

Moving
and Copying

Elements

The Move and Copy commands enable you to select the 
element(s) and move or copy them from one place to another. 
You can use alignment lines, temporary dimensions, and snaps 
to help place the elements, as shown in Figure 2–28.

Figure 2–28

Learning Objectives

Move and copy elements.

Rotate elements around the center or an origin.

Mirror elements by picking an axis or by drawing an axis.

Create Linear and Radial Arrays of elements.



Autodesk Revit MEP 2014 Fundamentals

2–22 © 2013, ASCENT - Center for Technical Knowledge®

How to: Move or Copy Elements

If you click  (Move) 
and hold down <Ctrl>, 
the elements are 
copied.

1. Select the elements you want to move or copy.

2. In the Modify panel, click  (Move) or  (Copy). A 
boundary box displays around the selected elements.

3. Select a move start point on or near the element.
4. Select a second point. Use alignment lines and temporary 

dimensions to help place the elements.
5. The elements remain highlighted, enabling you to start 

another command, or press <Esc> to finish.

Move/Copy Elements

The Move and Copy commands have several options that 
display in the Options Bar, as shown in Figure 2–29. 

Figure 2–29
 

 These commands only work within the current view, not 
between views or projects. To copy between views or 

projects, use  (Copy to Clipboard) and  (Paste).

Constrain Restricts the movement of the cursor to horizontal or vertical, 
or along the axis of an item that is at an angle. This keeps 
you from selecting a point at an angle by mistake. Constrain 
is off by default.

Disjoin 
(Move only)

Breaks any connections between the elements being moved 
and other elements. If Disjoin is on, the elements move 
separately. If it is off, the connected elements also move or 
stretch. Disjoin is off by default.

Multiple 
(Copy only)

Enables you to make multiple copies of one selection. 
Multiple is off by default.

Hint: Pinning Elements

If you do not want elements to be moved, you can  (Pin) 
them in place, as shown in Figure 2–30. Pinned elements can 
still be copied.

Figure 2–30

Select the element and click  (Unpin) to free it.



Basic Drawing and Editing Tools

© 2013, ASCENT - Center for Technical Knowledge® 2–23

Rotating
Elements

The Rotate command enables you to rotate selected elements 
around a center point or origin. You can use alignment lines, 
temporary dimensions, and snaps to help specify the center of 
rotation and the angle. You can also create copies of the element 
as it is being rotated.

How to: Rotate Elements

1. Select the element(s) you want to rotate.

2. In the Modify panel, click  (Rotate) or type RO.
3. The center of rotation is automatically set to the center of the 

element or group of elements, as shown on the left in 
Figure 2–31. To change the center of rotation, as shown on 
the right in Figure 2–31, use the following:

 Drag the  (Center of Rotation) control to a new point.

 In the Options Bar, next to Center of rotation, click  
and use snaps to move it to a new location.

 Press the <Spacebar> to select the center of rotation and 
click to move it to a new location.

Figure 2–31

 To start the Rotate command with an automatic prompt to 
select the center of rotation, type R3.

4. In the Options Bar, specify if you want to make a Copy (select 
Copy option), type an angle in the Angle field (as shown in 
Figure 2–32), and press <Enter>. You can also specify the 
angle on screen.

Figure 2–32



Autodesk Revit MEP 2014 Fundamentals

2–24 © 2013, ASCENT - Center for Technical Knowledge®

To specify the angle on 
screen, select a point for 
the rotate start ray (the 
reference line for the 
rotation angle). Then 
select a second point, 
using the temporary 
dimension to help you 
set the angle.

5. The rotated element(s) remain highlighted, enabling you to 
start another command, or press <Esc> to finish.

 The Disjoin option breaks any connections between the 
elements being rotated and other elements. If Disjoin is on 
(selected), the elements rotate separately. If it is off (cleared), 
the connected elements also move or stretch. Disjoin is off 
by default.

Mirroring
Elements

The Mirror command enables you to mirror elements about an 
axis defined by a selected element, as shown in Figure 2–33, or 
by selected points.

Figure 2–33

How to: Mirror Elements

1. Select the element(s) to mirror.
2. In the Modify panel, select the method you want to use:

 Click  (Mirror - Pick Axis) or type MM. This prompts 
you to select an element as the Axis of Reflection (mirror 
line).

 Click  (Mirror - Draw Axis) or type DM. This prompts 
you to select two points to define the axis about which the 
elements mirror.

3. The new mirrored element(s) remain highlighted, enabling 
you to start another command, or press <Esc> to finish.
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 By default, the original elements that were mirrored remain. 
To delete the original elements, clear the Copy option in the 
Options Bar.

Creating Linear
and Radial

Arrays

The Array command creates multiple copies of selected 
elements in a linear or radial pattern, as shown in Figure 2–34. 
For example, you can array a row of columns to create a row of 
evenly spaced columns on a grid, or array a row of parking 
spaces. The arrayed elements can be grouped or placed as 
separate elements.

 A linear array creates a straight line pattern of elements, 
while a radial array creates a circular pattern around a center 
point.

Figure 2–34

How to: Create a Linear Array

1. Select the element(s) to array. 

2. In the Modify panel, click  (Array). 

3. In the Options Bar, click  (Linear).
4. Specify the other options as needed.
5. Select a start point and an end point to set the spacing and 

direction of the array. The array is displayed.

Hint: Scale

The Autodesk Revit software is designed with full-size 
elements. Therefore, not much can be scaled. However, you 

can use  (Scale) in reference planes, images, and imported 
files from other programs.

Linear Array

Radial Array
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 If you have the Group and Associate option toggled on, you 
are prompted again for the number of items, as shown in 
Figure 2–35. 

Type a new number or 
click on the screen to 
finish the command.

Figure 2–35

 To make a linear array in two directions, you need to array 
one direction first, select the arrayed elements, and then 
array them again in the other direction.

Array Options

In the Options Bar, set up the Array options for Linear Array 
(top of Figure 2–36) or Radial Array (bottom of Figure 2–36).

Figure 2–36

Group and 
Associate

Creates a group element out of all arrayed elements. Groups 
can be selected by selecting any elements in the group.

Number Specifies how many instances you want in the array.

Move To: 2nd specifies the distance or angle between the center 
points of the two elements.

Last specifies the overall distance or angle of the entire 
array.

Constrain Restricts the direction of the array to only vertical or 
horizontal (Linear only).

Angle Specifies the angle (Radial only).

Center of 
rotation 

Specifies a location for the origin about which the elements 
rotate (Radial only).
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How to: Create a Radial Array

1. Select the element(s) to array. 

2. In the Modify panel, click  (Array).

3. In the Options Bar, click  (Radial).

4. Drag  (Center of Rotation) or use  to the move the 
center of rotation to the appropriate location, as shown in 
Figure 2–37.

Remember to set the 
Center of Rotation 
control first, because it 
is easy to forget to move 
it before specifying the 
angle.

Figure 2–37

5. Specify the other options as needed.
6. In the Options Bar, type an angle and press <Enter>, or 

specify the rotation angle by selecting points on the screen.

Modifying Arrays

When you select an element in an array that is created as a 
group, the associated shape controls and dimensions display, as 
shown in Figure 2–38. You can modify the number of instances 
and for radial arrays you can modify the distance to the center.

Figure 2–38

 To remove only the array constraint on the group, select one 

of the elements in the group and click  (Ungroup) in the 
Modify contextual tab>Group panel. This only ungroups the 
array but not the groups created when the array was created. 
To ungroup all of the elements, select the elements, use

 (Filter) to only select the groups, and click  (Ungroup). 
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2.4 Helpful Editing Tools

As you work on a project, some additional tools on the Modify 
tab>Modify panel, as shown in Figure 2–39, can help you with 
placing, modifying, and constraining elements. Align, Split, 
Trim, and Offset can be used with many types of linear 
elements.

Figure 2–39

Aligning
Elements

The Align command enables you to line up one element with 
another. Most Autodesk Revit elements can be aligned. For 
example, you can line up an air terminal with ceiling grids, as 
shown in Figure 2–40.

Figure 2–40

Learning Objective

Use modify tools to align, split, trim, and offset linear 
elements.
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How to: Align Elements

1. In the Modify tab>Modify panel, click  (Align) or type the 
shortcut AL.

2. Select a line or point on the element that is going to remain 
stationary. 

3. Select a line or point on the element to be aligned. The 
second element moves into alignment with the first one.

 The Align command works in both plan and elevation views.

 The Align command also works in 3D views. Make sure you 
select the correct component of the elements to align. For 
example, to line up two windows vertically select the side of 
the frame of each window. Zoom in if needed.

 You can lock alignments so that the elements move together 
if either one is moved. Once you have created the alignment, 
a padlock is displayed. Click on the padlock to lock it, as 
shown in Figure 2–41.

Locking elements 
enlarges the size of the 
project file, so use this 
option carefully.

Figure 2–41

 Select the Multiple Alignment option to select multiple 
elements to align with the first element, as shown in 
Figure 2–42. You can also hold down <Ctrl> to make multiple 
alignments.

 For walls, you can specify if you want the command to prefer 
Wall centerlines, Wall faces, Center of core, or Faces of 
core, as shown in Figure 2–42. The core refers to the 
structural members of a wall as opposed to facing materials, 
such as sheetrock.

Figure 2–42
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Splitting Linear
Elements

The Split command enables you to break a linear element at a 
specific point. You can use alignment lines, snaps, and 
temporary dimensions to help place the split point. After you 
have split the linear element, you can use other editing 
commands to modify it, such as changing the type in one 
section, as shown in Figure 2–43.

Figure 2–43

 There are two commands:  (Split Element) and  (Split 
with Gap).

How to: Split Linear Elements

1. In the Modify tab>Modify panel, click  (Split Element) or 
type the shortcut SL.

2. In the Options Bar, select or clear the Delete Inner Segment 
option, as needed.

3. Move the cursor to the point you want to split and select the 
point.

4. Repeat for any additional split locations.
5. Modify the items that were split, as needed.

 The Delete Inner Segment option is used when you select 
two split points along a linear element. When the option is 
selected, the segment between the two split points is 
automatically removed.
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  (Split with Gap) splits the linear element at the point you 
select, as shown in Figure 2–44, but also creates a Joint Gap 
specified in the Options Bar.

Figure 2–44

Trimming and
Extending

The Trim command enables you to either trim or extend linear 
elements. There are three trim methods: Trim/Extend to 
Corner, Trim/Extend Single Element, and Trim/Extend 
Multiple Elements.

 When selecting elements to trim, click the part of the element 
that you want to keep. The opposite part of the line is then 
trimmed.

How to: Trim/Extend to Corner

1. In the Modify tab>Modify panel, click  (Trim/Extend to 
Corner) or type the shortcut TR.

2. Select the first linear element on the side you want to keep.
3. Select the second linear element on the side you want to 

keep, as shown in Figure 2–45.

Figure 2–45

Split

Split with Gap

Before During After
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How to: Trim/Extend a Single Element

1. In the Modify tab>Modify panel, click  (Trim/Extend Single 
Element).

2. Select the cutting or boundary edge.
3. Select the linear element to be trimmed or extended, as 

shown in Figure 2–46.

Figure 2–46

How to: Trim/Extend Multiple Elements

1. In the Modify tab>Modify panel, click  (Trim/Extend 
Multiple Elements).

2. Select the cutting or boundary edge.
3. Select the linear elements that you want to trim or extend. For 

trimming, select the side you want to keep, as shown in 
Figure 2–47.

Figure 2–47

 You can click in an empty space to clear the selection and 
select another cutting edge or boundary.

Before During After

Before During After
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Offsetting
Elements

The Offset command enables you to create parallel copies of 
linear elements at a specified distance, as shown in Figure 2–48. 
Ducts, Pipes, Cable Tray, and Conduit can all be offset.

Figure 2–48

The offset distance can be set by typing the distance (Numerical 
method shown in Figure 2–49) or by selecting points on the 
screen (Graphical method).

Figure 2–49

How to: Offset using the Numerical Method

The Copy option (on by 
default) makes a copy of 
the element being 
offset. If this option is 
off, the Offset command 
moves the element.

1. In the Modify tab>Modify panel, click  (Offset) or type the 
shortcut OF.

2. In the Options Bar, select the Numerical option.
3. In the Options Bar, type the desired distance in the Offset 

field.
4. Move the cursor over the element you want to offset. A 

dashed line previews the offset location. Move the cursor to 
flip the sides, as needed.

5. Click to create the offset.
6. Repeat Steps 4 and 5 to offset other elements by the same 

distance, or to change the distance for another offset.
7. Press <Esc> or start another command to finish.
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 With the Numerical option, you can select multiple 
connected elements for offsetting. Hover your cursor over 
one element and press <Tab> until the required elements are 
highlighted, as shown in Figure 2–50. Select the elements to 
offset them. This enables you to offset all of them at once.

Figure 2–50

How to: Offset using the Graphical Method

1. Start the Offset command.
2. In the Options Bar, select the Graphical option.
3. Select the element to offset.
4. Select two points that define the distance of the offset and 

which side to apply it. You can type an override for the 
temporary dimension for the second point.

 When working with MEP elements (such as ducts), the offset 
element might not automatically connect to other nearby 
elements, as shown on the left in Figure 2–51. Drag the end 
of the new element away from the other element and then 
back again. It should connect as shown on the right in 
Figure 2–51. 

Figure 2–51
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Hiding Elements in Views

As you are working, you can hide individual elements or entire 
categories of elements to clarify the display. They remain 
hidden until you display them again.

 Select the element(s) you want to hide, right-click, and 
select Hide in view>Elements or Category.

 The Elements option hides only the elements you selected, 
while the Category option hides all elements in that 
category. For example, you can select one grid line and use 
Hide in view>Category to hide all of the grid lines.

 To see the elements or category again, in the View Control 

Bar, click  (Reveal Hidden Elements). The border and 
any hidden elements are displayed in magenta, while visible 
elements in the view are grayed out, as shown in 
Figure 2–52. Select the hidden elements you want to 
restore, right-click, and select Unhide in View>Elements or 
Category, or in the Reveal Hidden Elements contextual 

panel, click  (Unhide Element) or  (Unhide 
Category).

Figure 2–52
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Practice 2a Helpful Editing Tools

Estimated time for 
completion: 10 minutes

In this practice you will use temporary dimensions, controls, and 
snaps to modify the location of elements. You will than copy and 
move elements as well as rotate and align elements. The final 
version of the project is shown in Figure 2–53.

Figure 2–53

Task 1 - Use temporary dimensions and controls to modify 
elements.

1. Open the project file Simple-Building.rvt, found in the
Basics folder of your class files folder.

2. Select the AHU-1 unit in the hall of the building.

Learning Objectives

Use various drawing aids to modify the location of elements.

Copy, move, rotate, and align air terminals to match ceiling 
grids.
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3. Zoom in to the connectors/controls. Select the temporary 
dimension above the unit and change the distance to 2’-0", 
as shown in Figure 2–54.

The temporary 
dimensions work with 
the walls in this project 
because they are part of 
the project, not linked in.

Figure 2–54

4. The unit moves and the ducts move with it because the 
connectors control the location of the duct fittings and ducts. 

5. Pan over to the lower left room in the building. Select the tag 
that overlaps the ductwork as shown on the left in 
Figure 2–55.

6. In the Options Bar, select Leader.

7. Use the Move control to move the tag outside the room to a 
position in which it is not overlapping anything as shown on 
the right in Figure 2–55.

Figure 2–55

8. Zoom out to display the entire building. (Hint: Double-click the 
mouse wheel.)

9. Select the blue horizontal duct and use the Drag control to 
lengthen the duct so that it reaches into the room on the far 
right.

10.Click in empty space to clear the duct selection.
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11. The endcap of the duct did not move, as shown in 
Figure 2–56. Select and drag it to the endpoint of the duct.

Figure 2–56

12.Undo the change in duct length.

13.Select the duct endcap.

Because there is only one 
type of element selected, 
the specific type of 
element is displayed in 
the contextual tab.

14. In the Modify | Duct Fittings tab>Modify panel, click 

 (Move).

15.For the base point, select the duct endpoint.

16.Move it into the other room again. This time the endcap 
moves and the duct, which has a connector to the endcap, 
resizes as well.

Task 2 - Copy elements.

1. Select the Air Terminals and associated ductwork as shown 
in Figure 2–57.

Figure 2–57
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Because there is more 
than one type of element 
selected the contextual 
tab displays as 
Multi-Select.

2. In the Modify | Multi-Select tab>Modify panel, click

 (Copy).

3. In the Options Bar, select the Multiple option.

4. For the base point, select the endpoint of one of the vertical 
ducts as shown in Figure 2–58.

5. Copy the elements into the last room, as shown in 
Figure 2–58.

Figure 2–58

6. Press <Esc> twice to end the command.

Task 3 - Align and rotate elements.

1. In the Project Browser, open the view Mechanical>HVAC>
Ceiling Plans: 1- Ceiling Mech.

2. The air terminal locations do not match the ceiling grids as 
shown in Figure 2–59.

Figure 2–59

Base point for 

Base 
point
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3. Zoom in on the room to the left.

4. In the Modify tab>Modify panel, click  (Align).

5. Select a vertical grid line and then the edge of the air terminal 
as shown in Figure 2–60. The air terminal now lines up with 
the vertical pattern of the ceiling grid.

Figure 2–60

6. Repeat the process with the air terminal and the horizontal 
grid location. Select the edge of the grid line first and then the 
air terminal.

7. Repeat the process in both rooms so that the air terminals 
line up with the grids shown in Figure 2–61.

Figure 2–61

8. In the last room the ceiling grid is rotated. In this case you 
need to rotate the air terminals as well.
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9. Select one of the air terminals in the room with the rotated 
ceiling grid.

10. In the Modify | Air Terminals tab>Modify panel, click

 (Rotate).

11. In the Options Bar, set the angle to 45.

12.Use the Align command to move the air terminal to match 
the ceiling grid location. First you will select the ceiling grid 
line and then the edge of the air terminal.

13.The flex duct moves with the air terminal as shown 
Figure 2–62.

Figure 2–62

14.Without rotating the air terminal, click  (Align).

15.Select a grid line close to one of the other air terminals and 
then select the edge of the air terminal. The air terminal 
moves to touch the grid line and also rotates to match the 
angle of the grid line.

16.Finish aligning all of the air terminals in this room. The exact 
location is up to you.

17.Zoom out to display the entire building.
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18.Switch to the Mechanical>HVAC>Floor Plans: 1 - Mech 
view. The rotated terminals and flex duct display correctly in 
this view as well as shown in Figure 2–63.

Figure 2–63

19.Zoom out to display the entire building.

20.Save and close the model.
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Chapter Review Questions

1. What is the purpose of an alignment line?

a. Displays when the new element you are placing or 
drawing is aligned with the grid system.

b. Indicates that the new element you are placing or drawing 
is aligned with an existing object.

c. Displays when the new element you are placing or 
drawing is aligned with a selected tracking point.

d. Indicates that the new element is aligned with true north 
rather than project north.

2. How do you edit a temporary dimension, such as that shown 
in Figure 2–64, when you are drawing?

Figure 2–64

a. Select the temporary dimension and enter a new value.

b. Type a new value and press <Enter>.

c. Type a new value in the Distance/Length box in the 
Options Bar and press <Enter>.

3. How do you select only light fixtures in a view?

a. In the Family node in the Project Browser, select the Light 
Fixture category.

b. Select one light fixture, right-click and select Select All 
Instances>Visible in View.

c. Select all of the objects in the view and use  (Filter) to 
clear the other categories.

d. Select one light fixture, and click  (Select Multiple) in 
the Ribbon.
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4. What are the two methods for starting  (Move) or 

 (Copy)?

a. Start the command first and then select the objects, or 
select the objects and then start the command.

b. Start the command from the Modify tab, or select the 
object and then select Move or Copy from the right-click 
menu.

c. Start the command from the Modify tab, or select the 
objects and select Auto-Move.

d. Use the Move/Copy command or Cut/Copy and Paste 
using the Clipboard.

5. Both  (Rotate) and  (Array) with  (Radial) have a 
center of rotation that defaults to the center of the element or 
group of elements you have selected. How do you move the 
center of rotation to another point as shown in Figure 2–65? 
(Select all that apply.)

Figure 2–65

a. Select the center of rotation and drag it to a new location.

b. In the Options Bar, click  and select the new point.

c. In the Modify tab> Placement panel, click  (Center) and 
select the new point.

d. Right-click and select Snap Overrides>Centers and 
select the new point.
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6. Which editing command would you use to break part of a 
duct so that you can change the duct type?

a. .  (Align)

b.  (Split)

c. .  (Trim)

d.  (Offset)

7. All of the Trim commands can also be used to extend 
elements.

a. True

b. False

8. In the Mirror command, how do you remove the original 
element(s) if you do not want to keep them?

a. You must delete them separately from the command.

b. Use the Demolish tool.

c. Clear the Copy option in the Options Bar.

d. Select the Delete Original option in the Options Bar.

9. Which editing command do you use if you want two ducts to 
come together at a corner?

a.  (Edit Joins)

b.  (Trim/Extend to Corner)

c.  (Join Geometry)

d.  (Edit Profile) 
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Command Summary

Button Command Location
Add to 
Selection

 Ribbon: Edit Selection Set tab>Edit 
Selection panel

Array  Ribbon: Modify tab>Modify panel>
Array

 Shortcut: AR

Copy  Ribbon: Modify tab>Modify panel>
Copy

 Shortcut: CO

Copy to 
Clipboard

 Ribbon: Modify tab>Clipboard panel>
Copy to Clipboard

 Shortcut: <Ctrl>+<C>

Drag elements 
on selection

 Status Bar

 Expanded Select panel

Delete  Ribbon: Modify tab>Modify panel>
Delete

 Shortcut: DE

Edit (Selection)  Ribbon: Modify | Multi-Select tab>
Selection panel or Manage tab>
Selection panel

Filter  Ribbon: Modify | Multi-Select tab>
Filter panel>Filter

 Status Bar

Load 
(Selection)

 Ribbon: Modify | Multi-Select tab>
Selection panel or Manage tab>
Selection panel

Mirror - Draw 
Axis

 Ribbon: Modify tab>Modify panel>
Mirror

 Shortcut: DM

Mirror - Pick 
Axis

 Ribbon: Modify tab>Modify panel>
Mirror

 Shortcut: MM

Move  Ribbon: Modify tab>Modify panel>
Move

 Shortcut: MV

Paste  Ribbon: Modify tab>Clipboard panel>
Paste

 Shortcut: <Ctrl>+<V>

Pin  Ribbon: Modify tab>Modify panel>
Pin

 Shortcut: PN

Remove from 
Selection

 Ribbon: Edit Selection Set tab>Edit 
Selection panel
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Rotate  Ribbon: Modify tab>Modify panel>
Rotate

 Shortcut: RO

Save (Selection)  Ribbon: Modify | Multi-Select tab>
Selection panel or Manage tab>
Selection panel

Scale  Ribbon: Modify tab>Modify panel>
Scale

 Shortcut: RE

Select Elements 
By Face

 Status Bar

 Expanded Select panel

Select Links  Status Bar

 Expanded Select panel

Select Pinned 
Elements

 Status Bar

 Expanded Select panel

Select Underlay 
Elements

 Status Bar

 Expanded Select panel
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